Anuncio

Colapsar
No hay anuncio todavía.

No puedo hacer funcionar mi sitio en IIS

Colapsar
X
  • Filtrar
  • Tiempo
  • Mostrar
Limpiar Todo
nuevos mensajes

  • derman
    comenzado un tema No puedo hacer funcionar mi sitio en IIS

    No puedo hacer funcionar mi sitio en IIS

    Buenos dias,
    les cuento mi problema a ver si me pueden dar una mano u orientar porque se me acabaron las ideas:

    En un cliente, tengo un sitio web desarrollado en asp con base de datos sql server. El sitio lo tengo andando localmente en la dirección 18.18.18.8:8080.

    (no me pregunten porque, pero esa es la Ia dirección ip local que entrega el router).

    Hasta aqui todo perfecto.

    Ahora lo que quiero es publicar el sitio para accederlo por internet en el puerto 8080.

    Lo configuré hasta ahora en el router son cosas:

    1) Asignarle IP fija a la PC donde está corriendo el IIS (18.18.18.8)

    2) redireccionar el tráfico del puerto 8080 (TCP/UDP) a la IP 18.18.18.8.


    En otras ocasiones, haciendo esto mismo, ya era suficiente para acceder desde afuera al sitio, poniendo en el navegador la ip publica (que la obtengo con http://www.cualesmiip.com/), pero en esta ocasión al poner la ip publica + puerto 8080, no me carga el sitio.

    Otra cosa que hice fué abrir el puerto 8080 en el firewall. Tampoco carga el sitio.
    Desactivé el firewall. Tampoco carga el sitio.

    Si pongo en el navegador la ip publica pero sin el puerto 8080, entonces ahi me muestra el login del router.

    Se entiende cual es el problema? en el IIS el sitio web funciona en LAN, pero cuando quiero acceder desde afuera no carga. Me da error ERR_CONNECTION_REFUSED

    Por cierto, la PC donde está corriendo el IIS es un windows 7.

    Espero me puedan dar una mano porque ya no se que más hacer.

    Desde ya muchas gracias.


  • M·K·L
    respondió
    Hola derman ,

    Veamos, lo primero, en el router te has de asegurar que tanto el puerto externo como el interno sean el 8080. Si aún así no funciona es posible que se deba a factores externos, como que estés detrás de un proxy-caché, que la IP asignada por el ISP no sea única, etc.

    También probaría a deshabilitar el firewall de windows para probar si el problema está ahí.

    Saludos.

    Dejar un comentario:

Trabajando...
X